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1 Introduction
Microsoft™ Active Directory is one of the directory systems supported by the LANGuardian
Identity Module. The LANGuardian ldentity Module associates a username provided by the
directory with every network event and traffic flow that is recorded by LANGuardian.

This guide describes how to configure your LANGuardian and Active Directory to successfully

integrate the two products.
This guide is for LANGuardian Version 8.4.

For further information please contact support@netforttechnologies.com

2 Supported versions of Microsoft™ Active Directory
LANGuardian Version 8.4 supports:

e Windows Server 2008 R2
e Windows Server 2003 R2 (32 bit)
e Windows Server 2000
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3 Requirements

3.1

3.2

3.3

Domain Account

The LANGuardian requires an Active Directory Domain account that has been granted
sufficient privileges to read the Domain Controller Event Security Logs. The steps to
configure the account are described in section 4.1 Create and configure the Domain
Account.

If multiple Active Directory Domains are to be supported, then a separate account in each
domain is required.

Event Log Auditing

The LANGuardian requires that auditing for successful network logons are enabled on each
Domain Controller in the Domain. The steps to enable the auditing are described in section
4.2 Configuring the Eventlog Auditing.

LANGuardian License

The LANGuardian Identity Module is an optional module that must be enabled by loading
an appropriate license. The evaluation versions of LANGuardian (if you downloaded the
software)  automatically  support the Identity = Module. Please  contact
support@netforttechnologies.com for further information.
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4 Configuration steps

This guide describes the following steps which are required to enable Active Directory Support on
LANGuardian.

e (Create and configure the Domain Account

Configure the Event Log Auditing
e Configure the LANGuardian
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4.1 Create and configure the Domain Account

4.1.1 Create an account in the Active Directory Domain

ok wNE

Save the User Account

Logon to an Active Directory Domain Controller

Open Start -> Administration Tools -> Active Directory Users and Computers
Under the correct Domain, right click on Users and select New

Type in the user account details and click on next

Unselect the checkbox marked User must change password at next logon
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Configure the account Security attributes

Open Start -> Administration Tools -> Domain Controller Security Policy

Open Local Policies -> User Rights Assignments

Double click on Manage auditing and security log to open the Manage auditing and security log
Properties dialog.

Click on Add User or Group to open the Add User or Group dialog

Click on Browse to open the Select Users Computers or Groups dialog

Type the name of the account that you created in the domain as described in section 4.1.1

Click on Check Names button to correctly identify the domain account

Click the successive OK buttons to save the change

OPTIONAL STEP. To follow a practice of granting minimum required privilege to newly created
accounts, double click on Deny log on locally and repeat steps 4 to 8 above.

H i Default Domain Controller Security Settings =] I
File  Action Yiew Help
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Manage auditing and security log Properties

Security Policy Setting | Explain This Setting |

I Manage auditing and security log |
kg‘ Add User or Group

¥ Define these policy settings: |lzer and group names

i Administratars I @m@ -
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Screen shots of how to configuredomain account Security Attributes on Windows Server 2003
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4.2 Configure the Event Log Auditing

4.2.1 Check that the security event logs are set to a sufficient size

1.

2.
3.
4

Open Start > Administrative Tools -> Event Viewer

Right click on the Security Log

Select Properties

Set the Minimum Log size to 20 MB (20032 KB) and When Maximum log size is reached
to Overwrite events as needed.

B Event Viewer Security Properties

“General | Filter

File  Action view Help
= — ] : Dizplay name: Security
& m 2 | |
— Lag narme: |E:'\WINDDWS'\SystemEE'\cnnfingecEvent.Evt |
Event Yiewer {Local) | s 512.0 KB (524,288 bytes]
4| Application |_ Created: 01 September 2009 12:15:00
: Open Log File. .. A Modiied 23 March 2010 22:17.50
. : 23 March 2010 221750
Syskem Save Log File As. .. Acceassad:
Interne Log size

Mew Log Yiew

i e 70022 &
Clear all Events Feenlon ks 8

Whien masimum log size iz reached;

Wig 4 .
(#) Overwiite events as needed

Renarme () Overwiite events older than I:l days
Do ot ovenwite events
Refresh o [clear log marually] Restore Defaults

Expork List. ..
[]Using a low-speed connection

HE||:I OK H Cancel ][ Apply ]

Properkies
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4.2.2 Determine which type of event is suitable for your version of Active

Directory

The following table shows the options available for selecting events for Auditing

Server Windows Server version | Event Description Supported Event IDs
2008 R2 Logon Event 4624
2008 Logon Event 4624
2003 Logon Event 540
or or 672
Account Logon Event
2000 Account Logon Event 672

Table 1 — Supported Event types

4.2.3 Enable Auditing of Events

1. Open start -> Administrative tools -> Domain Contro

ller Security Policy

2. Click on Security Settings -> Local Policies -> Audit Policy
3. Enable Auditing for Success for your chosen Event ID (see Section 4.2.2)

'fiti Default Domain Controller Security Settings

File Action Wiew Help

& | Bm X B2

Y wireless Metwork (IEEE 802,11) F
-2 Public Key Policies

[#-[27] Software Restriction Policies
,g IP Security Policies on Active Dire

5 Security Settings Palicy [ Policy Setting [
g Account Policies Audit account logon events Success
E‘ Lcal Policies Audit account management Success
: Ea audic F|:|I||:';.-' _ Audit directory service access SUCCEss
User F_'l";hts .f'.ssn;nment BSTA0d logon events Success
i B-gp) Security Options Audit object access Mo auditing
ﬁ Event_ Log Audit policy change Success
#-_&) Restricted Groups - "
i ) Audlt privilege use Mo auditing
@ System Services . ) _ -
H ) P.ud|t process tracking Mo auditing
@ Reqiskry )
@ File System Audit swstem events Success
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4.2.4 Verify that events are being logged on the Domain Controller

1.

vk W

Open the Start -> Administrative Tools -> Event Viewer

Right click on Security -> View -> Filter

Enter your chosen event ID in the event ID field (see Section 4.2.2)
Click OK

Verify that events are listed
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5 Configure the LANGuardian

1. Open Configuration -> Configure support for Active Directory identity logging
Click on Auto-Discover
Select the Enter new credentials radio button
Type the password of the LANGuardian Domain Account in the Password field
Type the IP address of any Domain Controller in the Domain in the IP Address field
Click on the Search button

Active Directory: Domain Controllers

Domain Controllers ato discover

o vk wnN

O Jse existing credentials
(%) Enter a new credentials

User |Ianguardian |

Passward |-------.. |

IP Address 10.0.0.12 |

LANGuardian searches for all Domain Controllers in the Domain (even those that are not running) and
displays the results.

Active Directory: Domain Controllers Search result

Domain Controllers auto discover

Ouse existing credentials
@ Enter a new credentials

User |Ianguardian |

Password ||oo.ccco. |

IP Address [192.188.127.15 |

Search result.

Mame P Address U=er Crarmain “ersion

test1 192165127 155 languardian netforttest1 local 2003 F

] Save Selected



Corporate Headquarters
,Y P q
»> ‘4 N E T F O R T NetFort Technologies, Unit 7, IDA Innovation Centre, Upper Newcastle, Galway, Ireland
A TECHNOLOGIES Tel: +353 (0) 91 520 501 Fax: +353 (0) 91 526 571 Email: sales@netforttechnologies.com

7.

10.

11.

Select those Domain Controllers that should be queried to obtain user logon information.
As any Domain Controller on a Domain can authenticate users logging on to a Domain,
Netfort advise that all Domain Controllers in a Domain should be added. However, the
Administrator may elect to exclude some Domain Controllers that are known not to
authenticate any users (for examples DC’s on remote sites which may take a long time to
query).

Click on Save

Determine a suitable interval for LANGuardian to check for updates and changes to the
directory. This allows LANGuardian to detect when new users have been added to the
directory, or other setting such as email addresses for user have changed.

Select the correct update interval from the Update Directory information from AD
Controllers drop down list. Weekly is normally sufficient.

Lpdate Directary information from AD Cantrollers (this may take some time)

Update Interval: | weekly V[ Save H Update ]

Click on Save

12. This completes the Active Directory configuration.
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6 Editing the Domain Controller configuration on LANGuardian
After adding a Domain Controller to LANGuardian, you can review or edit the settings.

Open Configuration -> Configure support for Active Directory identity logging
Locate the Domain Controller in the table of known Domain Controllers
Click on the Edit button

Review the configuration or make changes as desired

Click on the Save button

uios N e

Active Directory: List of servers

o Add new server 2, Auto discower

Mame IP Adddress User Domain Wersion Status Test Dielete
METFORT-7362AED 192168127185 languardiant netforttest3.com 2003 & 0 K
WIN-ID4EIO0RJIE 192168127189 languardiani netforttests.com 20082 & 0 2} &

Update Directory infarmation fram AD Controllers (this may take some time)

Update Interval:|Never VH Save ” Update ]

Active Directory: Edit server "192.168.127.188"

ServerlP |192.168.127.188

Password |||rlrlvl|||

|
User |Ianguardian1 |
|
|

Dormain |netf0r1test3.u:nm

(& Logon Event (ID 540
EventlD O Account Logon Evant (ID 6T 2)
O 2008 Logon BEvent {10 4624

Save

Screenshot of editing Domain Controller configuration on LANGuardian
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7 Testing the Configuration
The LANGuardian Active Directory Configuration page helps test and troubleshoot the Active Directory
Configuration settings.

Open Configuration -> Configure support for Active Directory identity logging
Click on the Test All button
Review the result.

il

If the result looks the following, then the configuration has been completed successfully.

& Al listed Dormain Controllers have been fqueried. Please review individual server status
s ndd new server 2 Auto discover

5. If the result looks like the following, then there is an error in the configuration, move on
to step 6.

IE:H«II lizted Domain Controllers have been gqueried {errors found). Please review individual server status
andd new server ' Auto discover

6. Identify servers that are reporting errors and click on the test button for each
7. Review the informational messages and actions in Section 8

Active Directory: List of servers

& Failed to authenticate. Please verify user, passward and domain

ol Add new SEVET = FAutodiseove

Mame IP Address Uzer Damain Wersion Status Test Ediit Delete
METFORT-7362AED 192165127 1585 languardiand netorttest3.com 2003 & 0 "-'1 }6
WIN-I0461C0RJIE 1921651271589 languardiand netorttest3.com 2008R2 "-'1 }6

Update Directory infarmation fram AD Contrallers ¢this may take same time)

Update Interval:| Mever %

Screenshot showing server 192.168.127.189 reporting an error and the informational message
generated by clicking on the test button.
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Message

Description

Action

Server authenticated OK

The server was contacted, the
event log is readable and there
are logon events present.

No user action required. If you still
have problems with the
integration, please contact
support@netforttechnologies.com

Failed to connect to the server

The selected server cannot be
contacted

Check IP address of the Domain
Controller is specified correctly.

Check the Domain Controller is
running.

Check there is no ACL blocking
access to the Domain Controller.

Check the default router is
correctly set on LANGuardian

Failed to authenticate. Please
verify user, password and
domain

An LDAP connection and query
to the Domain Controller was
refused

Verify the Domain Account exists
(see section 4.1.1)

Verify the Domain Account and
Password are correctly entered on
LANGuardian

Verify the Domain specified on
LANGuardian exists

Failed to read Event Security
Log. Please verify the domain
account has sufficient rights

The specified Domain Account
does not have sufficient
permissions to read the Event
Security Log on the Domain
Controllers.

Verify the specified Domain
Account has rights to ‘Manage
auditing and Security Logs’ in the
Default Domain Controllers
Security Policy. See Section 4.1.2

'Windows 2000 Server must be
configured to use Account
Logon Event only

LANGuardian is attempting to
read an unsupported event type
from a Windows Server 2000
Domain Controller.

Edit the LANGuardian
configuration to specify Account
Logon Event for all Windows
Server 2000 Domain Controllers.
See Section 4.2.2.




SO2NETFORT

4 TECHNOLOGIES

Corporate Headquarters

NetFort Technologies, Unit 7, IDA Innovation Centre, Upper Newcastle, Galway, Ireland

Tel: +353 (0) 91 520 501

Fax: +353 (0) 91 526 571

Email: sales@netforttechnologies.com

'Failed to find a recent Logon
Event (ID 540) in the Security
Event log

LANGuardian connected to the
Domain Controller and accessed
the Event Security Log, but
could not find an Logon Event
logged there during the past 1
hour.

Verify the Domain Controller is
recoding Logon Events (ID 540) by
checking in the Event Viewer. See
sections 4.2.4,4.2.2 and 4.2.3

Failed to find a recent Account
Logon Event (ID 672) in

the Security Event log

LANGuardian connected to the
Domain Controller and accessed
the Event Security Log, but
could not find an Account Logon
Event logged there during the
past 1 hour.

Verify the Domain Controller is
recoding Account Logon Events (ID
672) by checking in the Event
Viewer. See sections 4.2.4,4.2.2
and 4.2.3

Windows 2008 Server must be
configured to use 2008 Logon
Event only

LANGuardian is attempting to
read an unsupported event type
from a Windows Server 2008 or
Windows 2008 R2 Domain
Controller.

Edit the LANGuardian
configuration to specify Account
Logon Event for all Windows
Server 2000 Domain Controllers.
See section 4.2.2.

Failed to find a recent 2008
Logon Event (ID 4624) in the
Security Event log

LANGuardian connected to the
Domain Controller and accessed
the Event Security Log, but
could not find an Account Logon
Event logged there during the
past 1 hour.

Verify the Domain Controller is
recoding Logon Events (ID 4626)
by checking in the Event Viewer.
See sections 4.2.4,4.2.2 and 4.2.3

An unknown error has occurred

Please contact
support@netforttechnologies.com

Table 2. Error messages and actions




